Cómo poner un led de actividad a tu Raspberry Pi 3

por 28 Abr 2020Makers1 Comentario

Compártelo en tus redes sociales. Gracias!

La Raspberry Pi tiene un led integrado de actividad. El problema es que dicho led, al estar integrado, en muchas ocasiones no se ve. En el caso que necesites poner otro led de actividad por ejemplo porque la raspberry la tienes metida dentro de una carcasa y el led no se ve, y necesitas saber si la Raspberry está encendida y funcionando con solo echar un vistazo, puedes añadir otro led de actividad que podrás colocar en cualquier sitio que sea más visible.

Para poner un led de actividad que parpadee según el uso que se le esté dando a la RaspBerry, tienes que unir cualquier GPIO de voltaje de la Raspberry, a 1 de las patillas del led, y la otra patilla del led la tienes que conectar a otro GPIO de datos, por ejemplo el GPIO 16. Entre este GPIO y la patilla del led deberías poner una resistencia de X ohmios, dependiendo de que tipo de led uses.

Una vez conectado, tienes que modificar el archivo /boot/config.txt y añadir la siguiente línea:

dtoverlay=pi3-act-led,gpio=XX

sustituyendo la XX por el numero de gpio al que has conectado la patilla del led al GPIO de datos de la Raspberry.

Si tu Raspberry es una Raspberry pi 2 o inferior, o una raspberry pi zero entonces en vez de añadir la linea anterior tendrás que añadir la siguiente: sustituyendo, también, la xx por el numero de GPIO:

dtparam=act_led_gpio=XX

Compártelo en tus redes sociales. Gracias!
<a href="https://dryant.com/author/dryant/" target="_self">dryant</a>

dryant

Webmaster de dryant.com

Informático, Maker, Inversor amateur, mente inquieta... Me encanta programar, esquiar, aprender, crear, bucear y jugar al baloncesto.

1 Comentario

  1. sergi

    buenos días

    una pregunta, quiero poner el led de actividad en una raspberry con recalbox, donde debo poner la linea de comando, en que archivo de configuración?? cuando conecto la sd se me abren 2 particiones, recalbox, y share. en recalbox esta el config.txt he puesto la linea al principio y nada. no se si lo estoy haciendo correctamente. el lead funciona lo he comprobado

    gracias por adelantado
    saludos

    Responder

Enviar un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Ver más

  • Responsable: Pedro Blanch Bejarano.
  • Finalidad:  Moderar los comentarios.
  • Legitimación:  Por consentimiento del interesado.
  • Destinatarios y encargados de tratamiento:  No se ceden o comunican datos a terceros para prestar este servicio. El Titular ha contratado los servicios de alojamiento web a IONOS que actúa como encargado de tratamiento.
  • Derechos: Acceder, rectificar y suprimir los datos.
  • Información Adicional: Puede consultar la información detallada en la Política de Privacidad.

Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para fines de afiliación y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Ver Política de cookies
Privacidad